Classroom - Investigating reports of degraded performance for select customers
Incident Report for Lightspeed Systems
Resolved
This incident has been resolved.
Posted Dec 08, 2020 - 19:45 CST
Investigating
We are currently investigating this issue.
Posted Dec 08, 2020 - 08:36 CST
This incident affected: Lightspeed Classroom Management™.