Inclement Weather and Power Outages in Texas
Incident Report for Lightspeed Systems
Resolved
This incident has been resolved.
Posted Feb 22, 2021 - 06:41 CST
Monitoring
Lightspeed Systems support capacity is diminished today due to widespread power outages and the severe weather situation in Texas.

What you need to know:
It may take longer to reach an agent or to hear back on your case.
Chat is still the best way to reach an agent if you need help.
We will prioritize cases by severity and impact.
All of our products remain operational and your students protected due to our cloud infrastructure.

We know you rely on us, and we take our mission seriously. Our teams have been working from home due to the pandemic, and today many of those homes are without power. In addition, snow and ice have made roads unsafe so our technicians aren’t able to reach our offices or another location that has power. We are adding capacity with our teams outside of Texas but increased delays could persist through the week as the emergency situation continues. Your patience is appreciated.

We know many of you are experiencing severe weather conditions as well. Stay safe and warm!
Posted Feb 16, 2021 - 09:49 CST