Lightspeed’s COVID-19 Continuity of Services
Scheduled for Mar 12, 15:18 CDT  -  Apr 24, 23:18 CDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 01, 2020 - 18:23 CDT
Scheduled
We know that COVID-19 is impacting schools around the world and that you are busily preparing to provide the best and safest education for your students, even during illness and potentially extended school closures.

You rely on us and our services to keep your students safe and we take that responsibility seriously. We have implemented processes to ensure uninterrupted services and support during the Coronavirus COVID-19 spread.
Here are some of the ways we will ensure continuity of services and support:
· We have developed work from home plans should our offices close or employees need to stay home
· We have processes that ensure employees are able to support you remotely
· We have redundancies in staff to ensure all services continue
· We have taken precautionary measures to decrease spread of illness among our staff
· And we have our products hosted with partners who have disaster and continuity plants that ensure availability of our hosted services
· We are closely following all news from the CDC and WHO and are adjusting our policies as new information is available
We are confident we are prepared to support you so that you can support your school communities during these challenging times.
· When you send school devices home with students, our filtering services will continue and students will be protected.
· Should you open up or extend remote learning, Classroom can ensure your students stay on task.

We are committed to protecting students – online and off – and are here to support you in that. We thank you for your continued trust in us and our products.
Posted Mar 12, 2020 - 15:16 CDT