[INCIDENT #14294]**Lightspeed Filter & UI/UX** Slow loading UI, Terms of Service Displaying, iOS Cloud Proxy connection issues as it relates to Google or YouTube
We are continuing to monitor for any further issues.
Posted Aug 20, 2025 - 14:51 CDT
Monitoring
Our engineering team have corrected the issue and we are confirming that all services are functional.
We will continue to monitor the situation and will provide a final update shortly.
Posted Aug 20, 2025 - 14:13 CDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 20, 2025 - 11:58 CDT
Identified
Our engineering team have identified the issue and are currently working to resolve it as quickly as possible. We will keep you updated with any developments and provide another update shortly.
Thank you for your patience and understanding.
Posted Aug 20, 2025 - 10:49 CDT
Investigating
We are actively investigating reports that Lightspeed Filter & UI/UX users may be experiencing slow loading UI, Terms of Service Displaying, iOS Cloud Proxy connection issues as it relates to Google or YouTube. This also includes possible prompts for teachers to sign into a-fallback-lightspeed.ably.io, when managing a class.
Our engineering team is working to resolve the issue and will provide another update shortly.
Posted Aug 20, 2025 - 10:41 CDT
This incident affected: Lightspeed Classroom™ and Lightspeed Filter™.