Support phone outage
Incident Report for Lightspeed Systems
Resolved
We have executed our disaster recovery plan and are now taking support calls at our secondary location.
Posted Aug 15, 2017 - 14:24 CDT
Identified
We've identified an issue with the phone/internet service provider; working to correct this now.
Posted Aug 15, 2017 - 14:04 CDT
Investigating
We are currently investigating and outage of our customer support telephone system.
Posted Aug 15, 2017 - 12:11 CDT