Support Phone System
Incident Report for Lightspeed Systems
Resolved
This incident has been resolved.
Posted Mar 06, 2019 - 15:07 CST
Update
We have not observed any more incidents in the past 24 hours and consider this resolved.
Posted Mar 06, 2019 - 15:05 CST
Monitoring
Phone services to our support phone system have been restored. We are continuing to monitor the issue to ensure all calls are received.
Posted Mar 05, 2019 - 08:33 CST
Investigating
Our support phone system is experiencing technical issues. Customers may experience issues when making calls into our support line at this time. Please email support@lightspeedsystems.com for any support requests as we work on resolving this issue.

We will continue to update this site as we have updates. We apologize for this disruption in our support services.
Posted Mar 05, 2019 - 03:51 CST