Chat Support
Incident Report for Lightspeed Systems
Resolved
Chat support services are back online.
Posted Feb 15, 2018 - 14:53 CST
Investigating
Our chat support client is currently offline. Please contact support via phone at 1-800-444-9267 for any support requests during this time.

We will continue to update this site as we have updates. We apologize for this disruption in our support services.
Posted Feb 15, 2018 - 14:25 CST
This incident affected: Lightspeed Customer Portal / Web Site.