launch.lightspeedsystems.com outage
Incident Report for Lightspeed Systems
Resolved
We have identified the cause of this outage and resolved the issue.
Posted Apr 24, 2017 - 08:26 CDT
Investigating
We are currently investigating an outage of launch.lightspeedsystems.com.
Posted Apr 24, 2017 - 08:08 CDT
This incident affected: Launch Dashboard.