Inbound E-mail Outage
Incident Report for Lightspeed Systems
Resolved
We've identified and resolved an inbound e-mail issue, e-mail message flow is now working as expected.
Posted Sep 22, 2017 - 11:10 CDT
Investigating
Investigating e-mail flow issues.
Posted Sep 22, 2017 - 10:05 CDT